• To improve performance and better customer
    experience we are maintaining our server.
    If you are getting login issues then
    please send an email at "themehunk@gmail.com"
  • Your query is valuable for us, you can post your query any time.
    We are ON in week days. You will get instant support in our working hours.
    We are little slow in non-working hours, but you will get response in maximum 24 hours.
    Our working timing is
    [10:00 AM (IST) - 7:00 PM (IST)]
    [6:30 AM (CET)- 3:30 PM (CET)]
    [12:30 AM (EST) - 9:30 AM (EST)]

    Login Rules
    1. Premium users can login directly using aMember credentials, Created at the time of purchase.
    2. Free users can re-register to access forum using this link : Register Here.

FeaturedLite page hangs on spinning circle

#1
Hi

I am not sure to upgrade FeaturedLite to Featured Pro.

I see instances of FeaturedLite websites that do no load page, either on first visit or on page refresh/reload.
The issue is seen as a permanently spinning circle as if the page has stalled or hung.
The issue is not consistent. Sometimes the subject page will fully load and display OK, other times it appears to hang with only the spinning circle.

Obvious example is ThemeHunk FeaturedLite demo page at
https://support.themehunk.com/wp-themes/featuredlite/blog/
Sometimes that page will load on first landing; sometimes it needs a refresh; sometimes after successful load a subsequent refresh will not load.

The first time I visited page below on W10 desktop Firefox it took two reloads before the page successfully progressed past spinning circle to display content.
https://support.themehunk.com/wp-themes/featuredlite/2016/10/05/interview-meet/
On Android Brave mobile browser via cellular data, that page loaded on first visit but subsequent multiple refreshes did not load.

The same issue is experienced on multiple device types regardless of internet source (infrastructure wired/wifi or cellular) or desktop or mobile browsers, but the issue is not consistent.
In all instances of issue the browser extensions / add-ons have been disabled.

Please indicate if live Pro site would experience same issue.

Regards
 

Satyendraa

Moderator
Staff member
#2
Hello there,

I have checked both our demo links and they are loaded without any problem.
please share your site URL, so i can take a look.

Best Regards
 
#7
Unfortunately I have the same issue and I don't know how to resolve it.

Regards.
Assuming the perpetual spinning circle appears on first visit and/or subsequent (multiple) refresh(es), I found 4 blunt workarounds without any assistance from TH support:

1) Not ideal, but rollback to WP 5.5.4, on the basis that 5.5.4 does not exhibit the perpetual spinning circle issue but 5.6 or later may exhibit the issue on first visit to a page and/or subsequent refresh(es) of the page.
or
2) Include any functional iframe content within all specific problematic page(s). The simplest iframe to use may be the iframe map lifted from the demo homepage (but obviously with location amended to your requirement).
or
3) Force all your website visitors to use an aggressive browser that natively strips out certain scripts, such as Epic Privacy Browser, although obviously that is utterly impractical to enforce.
or
4) Easiest route: abandon and use a more stable theme having better compatibility with later versions of WP from 5.6, considering current WP version has progressed to 5.8 at time of this post.
 
#10
Thank you @PatienceSaint ,

I have tried to rollback to WP 5.5.4, but unfortunately it doesn't work in my case.

Obviously the only way to resolve this issue is chenging a theme.
Wow, so same perpetual spinning circle issue but resulting from different symptoms!

Purely out of interest, have you attempted to add some random iframe content to a problematic page to see if the issue ceases?